What is the error? Plugin Towny v0.96.7.4 has failed to register events

Hey!
I think part of the community knows about the plugin Pokkit That is, it is a converter n SPIGOT on Nukkit , and so the problem came out that one plugin out of 5 did not load, and this Towny , this is what the console outputs:

Plugin Towny v0.96.7.4 has failed to register events for class com.palmergames.bukkit.towny.listeners.TownyPlayerListener because org/bukkit/event/player/PlayerTakeLecternBookEvent does not exist.

Is it possible to fix the plugin somehow?

Hi, apparently the Pokkit plugin does not support the plugins that use PlayerTakeLecternBookEvent.

The Pokkit readme says that only a few plugins work and shares this list of working plugins:

TownyAdvanced 1.13.2 is being listed as compatible but I couldn’t test on PowerNukkit myself.

Since it’s a protection plugin, I have low expectations that it would work flawlessly on PowerNukkit and might have many bypasses.

I recommend using a PowerNukkit or Nukkit protection plugin instead: