Minecraft 1.17.2 was released and PowerNukkit is already compatible!

Hello guys! I’m just passing by to say that Mojang has released the Minecraft 1.17.2 Bedrock Edition today but they didn’t do any changes to the client-server protocol, so PowerNukkit 1.5.0.0-PN and the upcoming 1.5.1.0-PN-SNAPSHOT are already compatible with it. You don’t need to execute any update today to get compatibility and support for it.

I also would like to say that 1.5.1.0-PN-SNAPSHOT is getting close to being released and is currently the recommended version today because 1.5.0.0-PN has some runtime item id mapping bugs which cause some items to look like instead of what they actually are, they aren’t many, but don’t be surprised if you try to craft a sign and get 3 “netherite scraps” instead, they are not really netherite scraps, the are disguised signs :stuck_out_tongue:


(Screenshot from our Discord guild. Join today: https://powernukkit.org/discord - Original messages)